Read the docs
TI-2024-14394 Aliases CVE-2024-21673GHSA-jp7h-g39h-xfp6

Code injection in Atlassian Confluence Data Center

Priority MEDIUM 43CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-94.

Summary

This High severity Remote Code Execution (RCE) vulnerability was introduced in versions 7.13.0 of Confluence Data Center and Server. Remote Code Execution (RCE) vulnerability, with a CVSS Score of 8.0 and a CVSS Vector of CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H allows an authenticated attacker to expose assets in your environment susceptible to exploitation which has high impact to confidentiality, high impact to integrity, high impact to availability, and does not require user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release 7.19.18, or any higher 7.19.x release * Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release * Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives ).

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01504 74th percentileScored 2026-11-07
Fix Fixed Confluence Data Center (Atlassian): < 7.13.0, >= 7.19.18, >= 8.5.5 +1Confluence Server (Atlassian): < 7.13.0, >= 7.19.18, >= 8.5.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AtlassianConfluence Data Center>= 7.13.0; >= 7.19.0; >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.6.0; >= 8.7.1< 7.13.0, >= 7.19.18, >= 8.5.5, >= 8.7.2Patch availableCNA
AtlassianConfluence Server>= 7.13.0; >= 7.19.0; >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.6.0; >= 8.7.1< 7.13.0, >= 7.19.18, >= 8.5.5Patch availableCNA
  • Confluence Data Center VendorAtlassian Affected >= 7.13.0; >= 7.19.0; >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.6.0; >= 8.7.1 Fixed in < 7.13.0, >= 7.19.18, >= 8.5.5, >= 8.7.2 Patch available CNA
  • Confluence Server VendorAtlassian Affected >= 7.13.0; >= 7.19.0; >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.6.0; >= 8.7.1 Fixed in < 7.13.0, >= 7.19.18, >= 8.5.5 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:*7.19.0 to before 7.19.18; 8.5.0 to before 8.5.5; 8.7.0 to before 8.7.2VulnerableAtlassian
cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*7.19 to before 7.19.18; 8.5.0 to before 8.5.5; 8.7.0 – 8.7.2VulnerableAtlassian
  • cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions 7.19.0 to before 7.19.18; 8.5.0 to before 8.5.5; 8.7.0 to before 8.7.2 Vulnerable ·Atlassian
  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions 7.19 to before 7.19.18; 8.5.0 to before 8.5.5; 8.7.0 – 8.7.2 Vulnerable ·Atlassian

Remediation

  • Fix · CNA Confluence Data Center (Atlassian) Fixed in < 7.13.0, >= 7.19.18, >= 8.5.5, >= 8.7.2
  • Fix · CNA Confluence Server (Atlassian) Fixed in < 7.13.0, >= 7.19.18, >= 8.5.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-21673
  2. 2026-10-03 Alias added: GHSA-jp7h-g39h-xfp6

References

  • TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
  • TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
See all 38 →

Sources