Path traversal in Atlassian Confluence Data Center
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
This High severity Path Traversal vulnerability was introduced in version 6.13.0 of Confluence Data Center. This Path Traversal vulnerability, with a CVSS Score of 8.3, allows an unauthenticated attacker to exploit an undefinable vulnerability which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Data Center Atlassian recommends that Confluence Data Center customers upgrade to the latest version and that Confluence Server customers upgrade to the latest 8.5.x LTS version. If you are unable to do so, upgrade your instance to one of the specified supported fixed versions See the release notes https://confluence.atlassian.com/doc/confluence-release-notes-327.html You can download the latest version of Confluence Data Center and Server from the download center https://www.atlassian.com/software/confluence/download-archives. This vulnerability was reported via our Bug Bounty program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | >= 6.13.0; >= 7.19.0; >= 7.20.0; >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.6.0; >= 8.7.1; >= 8.8.0 | < 6.13.0, >= 7.19.20, >= 8.5.7, >= 8.8.1 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected >= 6.13.0; >= 7.19.0; >= 7.20.0; >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.6.0; >= 8.7.1; >= 8.8.0 Fixed in < 6.13.0, >= 7.19.20, >= 8.5.7, >= 8.8.1 Patch available CNA
CPE configurations NVD · 2
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in < 6.13.0, >= 7.19.20, >= 8.5.7, >= 8.8.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21677
- 2026-10-03 Alias added: GHSA-vcmw-wwpg-fvfx
References
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-21677 · CVE Program
- CVE-2024-21677 · NVD
- FIRST EPSS
- GHSA-vcmw-wwpg-fvfx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences