Read the docs
TI-2024-14402 Aliases CVE-2024-21686GHSA-7x4x-g7pr-2356

Cross-site scripting in Atlassian Confluence Data Center

Priority MEDIUM 41CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

This High severity Stored XSS vulnerability was introduced in versions 7.13 of Confluence Data Center and Server. This Stored XSS vulnerability, with a CVSS Score of 7.3, allows an authenticated attacker to execute arbitrary HTML or JavaScript code on a victims browser which has high impact to confidentiality, high impact to integrity, no impact to availability, and requires user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions listed on this CVE See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives). This vulnerability was reported via our Bug Bounty program.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0089 59th percentileScored 2026-11-07
Fix Fixed Confluence Data Center (Atlassian): 8.9.1 to 8.9.4, 8.5.9 to 8.5.12, 7.19.22 to 7.19.25Confluence Server (Atlassian): 8.5.9 to 8.5.12, 7.19.22 to 7.19.25

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AtlassianConfluence Data Center8.9.0; 8.8.0 to 8.8.1; 8.7.1 to 8.7.2; 8.6.0 to 8.6.2; 8.5.0 to 8.5.8; 8.4.0 to 8.4.5; 8.3.0 to 8.3.4; 8.2.0 to 8.2.3; 8.1.0 to 8.1.4; 8.0.0 to 8.0.4; 7.20.0 to 7.20.3; 7.19.0 to 7.19.218.9.1 to 8.9.4, 8.5.9 to 8.5.12, 7.19.22 to 7.19.25Patch availableCNA
AtlassianConfluence Server8.5.0 to 8.5.8; 8.4.0 to 8.4.5; 8.3.0 to 8.3.4; 8.2.0 to 8.2.3; 8.1.0 to 8.1.4; 8.0.0 to 8.0.4; 7.20.0 to 7.20.3; 7.19.0 to 7.19.218.5.9 to 8.5.12, 7.19.22 to 7.19.25Patch availableCNA
  • Confluence Data Center VendorAtlassian Affected 8.9.0; 8.8.0 to 8.8.1; 8.7.1 to 8.7.2; 8.6.0 to 8.6.2; 8.5.0 to 8.5.8; 8.4.0 to 8.4.5; 8.3.0 to 8.3.4; 8.2.0 to 8.2.3; 8.1.0 to 8.1.4; 8.0.0 to 8.0.4; 7.20.0 to 7.20.3; 7.19.0 to 7.19.21 Fixed in 8.9.1 to 8.9.4, 8.5.9 to 8.5.12, 7.19.22 to 7.19.25 Patch available CNA
  • Confluence Server VendorAtlassian Affected 8.5.0 to 8.5.8; 8.4.0 to 8.4.5; 8.3.0 to 8.3.4; 8.2.0 to 8.2.3; 8.1.0 to 8.1.4; 8.0.0 to 8.0.4; 7.20.0 to 7.20.3; 7.19.0 to 7.19.21 Fixed in 8.5.9 to 8.5.12, 7.19.22 to 7.19.25 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:*before 7.19.22; 7.20.0 to before 8.5.9; 8.6.0 to before 8.9.1VulnerableAtlassian
cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*before 7.19.22; 7.20.0 to before 8.5.9VulnerableAtlassian
  • cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions before 7.19.22; 7.20.0 to before 8.5.9; 8.6.0 to before 8.9.1 Vulnerable ·Atlassian
  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions before 7.19.22; 7.20.0 to before 8.5.9 Vulnerable ·Atlassian

Remediation

  • Fix · CNA Confluence Data Center (Atlassian) Fixed in 8.9.1 to 8.9.4, 8.5.9 to 8.5.12, 7.19.22 to 7.19.25
  • Fix · CNA Confluence Server (Atlassian) Fixed in 8.5.9 to 8.5.12, 7.19.22 to 7.19.25

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-21686
  2. 2026-10-03 Alias added: GHSA-7x4x-g7pr-2356

References

  • TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
  • TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
See all 38 →

Sources