Incorrect permission assignment in Atlassian Confluence Data Center
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
This Medium severity Security Misconfiguration vulnerability was introduced in version 8.8.1 of Confluence Data Center and Server for Windows installations. This Security Misconfiguration vulnerability, with a CVSS Score of 6.4 allows an authenticated attacker of the Windows host to read sensitive information about the Confluence Data Center configuration which has high impact to confidentiality, high impact to integrity, high impact to availability, and no user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to the latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release greater than or equal to 7.19.18 * Confluence Data Center and Server 8.5: Upgrade to a release greater than or equal to 8.5.5 * Confluence Data Center and Server 8.7: Upgrade to a release greater than or equal to 8.7.2 * Confluence Data Center and Server 8.8: Upgrade to a release greater than or equal to 8.8.0 See the release notes (https://confluence.atlassian.com/conf88/confluence-release-notes-1354501008.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives ). This vulnerability was reported via our Atlassian Bug Bounty Program by Chris Elliot.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | 8.7.1 | 8.8.0 to 8.8.1, 8.7.2, 8.5.5 to 8.5.17, 7.19.18 to 7.19.29 | Patch available | CNA |
| Atlassian | Confluence Server | — | 8.5.5 to 8.5.17, 7.19.18 to 7.19.29 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected 8.7.1 Fixed in 8.8.0 to 8.8.1, 8.7.2, 8.5.5 to 8.5.17, 7.19.18 to 7.19.29 Patch available CNA
- Confluence Server VendorAtlassian Affected — Fixed in 8.5.5 to 8.5.17, 7.19.18 to 7.19.29 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* | before 7.19.18; 8.5 to before 8.5.5; 8.7 to before 8.7.2 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* | before 7.19.18; 8.0.0 to before 8.5.5 | Vulnerable | Atlassian |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions before 7.19.18; 8.5 to before 8.5.5; 8.7 to before 8.7.2 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions before 7.19.18; 8.0.0 to before 8.5.5 Vulnerable ·Atlassian
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in 8.8.0 to 8.8.1, 8.7.2, 8.5.5 to 8.5.17, 7.19.18 to 7.19.29
- Fix · CNA Confluence Server (Atlassian) Fixed in 8.5.5 to 8.5.17, 7.19.18 to 7.19.29
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21703
- 2026-10-03 Alias added: GHSA-gmcv-67g3-vrwj
References
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-21703 · CVE Program
- CVE-2024-21703 · NVD
- FIRST EPSS
- GHSA-gmcv-67g3-vrwj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences