Undici's Proxy-Authorization header not cleared on cross-origin redirect for dispatch, request, stream, pipeline
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass, Information disclosure
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-285 and CWE-200.
Summary
Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici cleared Authorization and Proxy-Authorization headers for `fetch()`, but did not clear them for `undici.request()`. This vulnerability was patched in version(s) 5.28.4 and 6.11.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | undici | before 5.28.4; 6.0.0 to before 6.11.1 | 5.28.4, 6.11.1 | Patch available | CNA |
| — | undici (npm) | before 5.28.4 | 5.28.4 | Patch available | GHSA-m4v8-wqvr-p9f7 |
| — | undici (npm) | 6.0.0 to before 6.11.1 | 6.11.1 | Patch available | GHSA-m4v8-wqvr-p9f7 |
- undici VendorNodeJS Affected before 5.28.4; 6.0.0 to before 6.11.1 Fixed in 5.28.4, 6.11.1 Patch available CNA
- undici (npm) Vendor— Affected before 5.28.4 Fixed in 5.28.4 Patch available GHSA-m4v8-wqvr-p9f7
- undici (npm) Vendor— Affected 6.0.0 to before 6.11.1 Fixed in 6.11.1 Patch available GHSA-m4v8-wqvr-p9f7
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:* | before 5.28.4; 6.0.0 to before 6.11.1 | Vulnerable | NodeJS |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* | 40 | Vulnerable | Fedoraproject |
- cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:* Versions before 5.28.4; 6.0.0 to before 6.11.1 Vulnerable ·NodeJS
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* Versions 40 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA undici (nodejs) Fixed in 5.28.4, 6.11.1
- Fix · GHSA-m4v8-wqvr-p9f7 undici (npm) Fixed in 5.28.4 Advisory →
- Fix · GHSA-m4v8-wqvr-p9f7 undici (npm) Fixed in 6.11.1 Advisory →
Red Hat 1 advisory
- RHSA-2024:6667 Released 2024-09-12 · Red Hat rating ImportantRed Hat OpenShift Dev Spaces 3.16.0 release
- Red Hat OpenShift Dev Spaces 3 devspaces/code-rhel8, devspaces/configbump-rhel8, devspaces/dashboard-rhel8 +10
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Dev Spaces 3 | Fixed | RHSA-2024:6667 |
Not affected: 2 products
- Red Hat Enterprise Linux 10
- Red Hat OpenShift Dev Spaces 3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-30260
- 2026-10-03 Alias added: GHSA-m4v8-wqvr-p9f7
References
Patch 3
Other 9
- https://lists.fedoraproject.org/archives/list/[email protected]/message/P6Q4RGETHVYVHDIQGTJGU5AV6NJEI67E/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/HQVHWAS6WDXXIU7F72XI55VZ2LTZUB33/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/NC3V3HFZ5MOJRZDY5ZELL6REIRSPFROJ/
- https://hackerone.com/reports/2408074
- https://github.com/nodejs/undici
- https://lists.fedoraproject.org/archives/list/[email protected]/message/HQVHWAS6WDXXIU7F72XI55VZ2LTZUB33
- https://lists.fedoraproject.org/archives/list/[email protected]/message/NC3V3HFZ5MOJRZDY5ZELL6REIRSPFROJ
- https://lists.fedoraproject.org/archives/list/[email protected]/message/P6Q4RGETHVYVHDIQGTJGU5AV6NJEI67E
- https://security.netapp.com/advisory/ntap-20240905-0008
More NodeJS Undici vulnerabilities
- TI-2026-01215 undici is vulnerable to Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') CVSS 3.1CRITICAL 9.8
- TI-2022-16376 `undici.request` vulnerable to SSRF using absolute URL on `pathname` CVSS 3.1CRITICAL 9.8
- TI-2023-09734 CRLF Injection in Nodejs ‘undici’ via host CVSS 3.1MEDIUM 6.5
- TI-2022-13193 CRLF injection in request headers CVSS 3.1MEDIUM 6.5
- TI-2022-16375 CRLF Injection in Nodejs ‘undici’ via Content-Type CVSS 3.1MEDIUM 5.3
- TI-2022-13194 Uncleared cookies on cross-host/cross-origin redirect in undici CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-30260 · CVE Program
- CVE-2024-30260 · NVD
- FIRST EPSS
- GHSA-m4v8-wqvr-p9f7 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-30260 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences