LibreNMS's Improper Sanitization on Service template name leads to Stored XSS
Priority MEDIUM 56CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to version 24.4.0, there is improper sanitization on the `Service` template name, which can lead to stored Cross-site Scripting. Version 24.4.0 fixes this vulnerability.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.34128 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms (librenms): 24.4.0librenms/librenms (Packagist): 24.4.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 24.4.0 | 24.4.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 24.4.0 | 24.4.0 | Patch available | GHSA-72m9-7c8x-pmmw |
- librenms Vendorlibrenms Affected before 24.4.0 Fixed in 24.4.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 24.4.0 Fixed in 24.4.0 Patch available GHSA-72m9-7c8x-pmmw
Remediation
- Fix · CNA librenms (librenms) Fixed in 24.4.0
- Fix · GHSA-72m9-7c8x-pmmw librenms/librenms (Packagist) Fixed in 24.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32479
- 2026-10-03 Alias added: GHSA-72m9-7c8x-pmmw
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-32479 · CVE Program
- CVE-2024-32479 · NVD
- FIRST EPSS
- GHSA-72m9-7c8x-pmmw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences