LibreNMS's Time-Based Blind SQL injection leads to database extraction
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Versions prior to 24.4.0 are vulnerable to SQL injection. The `order` parameter is obtained from `$request`. After performing a string check, the value is directly incorporated into an SQL statement and concatenated, resulting in a SQL injection vulnerability. An attacker may extract a whole database this way. Version 24.4.0 fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 24.4.0 | 24.4.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 24.4.0 | 24.4.0 | Patch available | GHSA-jh57-j3vq-h438 |
- librenms Vendorlibrenms Affected before 24.4.0 Fixed in 24.4.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 24.4.0 Fixed in 24.4.0 Patch available GHSA-jh57-j3vq-h438
Remediation
- Fix · CNA librenms (librenms) Fixed in 24.4.0
- Fix · GHSA-jh57-j3vq-h438 librenms/librenms (Packagist) Fixed in 24.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32480
- 2026-10-03 Alias added: GHSA-jh57-j3vq-h438
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-32480 · CVE Program
- CVE-2024-32480 · NVD
- FIRST EPSS
- GHSA-jh57-j3vq-h438 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences