WooCommerce has a Cross-Site Scripting Vulnerability in checkout & registration forms
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
WooCommerce is an open-source e-commerce platform built on WordPress. A vulnerability introduced in WooCommerce 8.8 allows for cross-site scripting. A bad actor can manipulate a link to include malicious HTML & JavaScript content. While the content is not saved to the database, the links may be sent to victims for malicious purposes. The injected JavaScript could hijack content & data stored in the browser, including the session. The URL content is read through the `Sourcebuster.js` library and then inserted without proper sanitization to the classic checkout and registration forms. Versions 8.8.5 and 8.9.3 contain a patch for the issue. As a workaround, one may disable the Order Attribution feature.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WooCommerce | woocommerce | 8.8.0 to before 8.8.5; 8.9.0 to before 8.9.3 | 8.8.5, 8.9.3 | Patch available | CNA |
| — | woocommerce/woocommerce (Packagist) | 8.8.0 to before 8.8.5 | 8.8.5 | Patch available | GHSA-cv23-q6gh-xfrf |
| — | woocommerce/woocommerce (Packagist) | 8.9.0 to before 8.9.3 | 8.9.3 | Patch available | GHSA-cv23-q6gh-xfrf |
- woocommerce VendorWooCommerce Affected 8.8.0 to before 8.8.5; 8.9.0 to before 8.9.3 Fixed in 8.8.5, 8.9.3 Patch available CNA
- woocommerce/woocommerce (Packagist) Vendor— Affected 8.8.0 to before 8.8.5 Fixed in 8.8.5 Patch available GHSA-cv23-q6gh-xfrf
- woocommerce/woocommerce (Packagist) Vendor— Affected 8.9.0 to before 8.9.3 Fixed in 8.9.3 Patch available GHSA-cv23-q6gh-xfrf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* | 8.8 to before 8.8.5; 8.9.0 to before 8.9.3 | Vulnerable | WooCommerce |
- cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* Versions 8.8 to before 8.8.5; 8.9.0 to before 8.9.3 Vulnerable ·WooCommerce
Remediation
- Fix · CNA woocommerce (woocommerce) Fixed in 8.8.5, 8.9.3
- Fix · GHSA-cv23-q6gh-xfrf woocommerce/woocommerce (Packagist) Fixed in 8.8.5 Advisory →
- Fix · GHSA-cv23-q6gh-xfrf woocommerce/woocommerce (Packagist) Fixed in 8.9.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-37297
- 2026-10-03 Alias added: GHSA-cv23-q6gh-xfrf
References
Patch 3
More Woocommerce vulnerabilities
- TI-2022-00684 WooCommerce < 6.2.1 - Subscriber+ Arbitrary Comment Deletion CVSS 3.1MEDIUM 4.3
- TI-2017-13530 In the Automattic WooCommerce plugin before 3.2.4 for WordPress, an attack is possible… CVSS 3.0HIGH 8.8
- TI-2019-15109 WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site… CVSS 3.1HIGH 8.8
- TI-2018-14697 The logging system of the Automattic WooCommerce plugin before 3.4.6 for WordPress is… CVSS 3.0HIGH 8.1
- TI-2023-28650 WordPress WooCommerce Plugin <= 8.2.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-09228 WooCommerce <= 9.0.2 - Unauthenticated HTML Injection CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-37297 · CVE Program
- CVE-2024-37297 · NVD
- FIRST EPSS
- GHSA-cv23-q6gh-xfrf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences