LibreNMS has a Self-XSS ('Cross-site Scripting') in librenms/includes/html/modal/alert_template.inc.php
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Self Cross-Site Scripting (Self-XSS) vulnerability in the "Alert Templates" feature allows users to inject arbitrary JavaScript into the alert template's name. This script executes immediately upon submission but does not persist after a page refresh.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 24.9.0 | 24.9.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 24.9.0 | 24.9.0 | Patch available | GHSA-gcgp-q2jq-fw52 |
- librenms Vendorlibrenms Affected before 24.9.0 Fixed in 24.9.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 24.9.0 Fixed in 24.9.0 Patch available GHSA-gcgp-q2jq-fw52
Remediation
- Fix · CNA librenms (librenms) Fixed in 24.9.0
- Fix · GHSA-gcgp-q2jq-fw52 librenms/librenms (Packagist) Fixed in 24.9.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47526
- 2026-10-03 Alias added: GHSA-gcgp-q2jq-fw52
References
Other 3
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-47526 · CVE Program
- CVE-2024-47526 · NVD
- FIRST EPSS
- GHSA-gcgp-q2jq-fw52 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences