Read the docs
TI-2024-31817 Aliases CVE-2024-47528GHSA-x8gm-j36p-fppf

LibreNMS Contains a Stored XSS via File Upload

Priority MEDIUM 54CWE-116Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Code execution, Cross-site scripting
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-434 and CWE-79.

Summary

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Stored Cross-Site Scripting (XSS) can be achieved by uploading a new Background for a Custom Map. Users with "admin" role can set background for a custom map, this allow the upload of SVG file that can contain XSS payload which will trigger on load. This led to Stored Cross-Site Scripting (XSS). The vulnerability is fixed in 24.9.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00411 35th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms (librenms): 24.9.0librenms/librenms (Packagist): 24.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
librenmslibrenmsbefore 24.9.024.9.0Patch availableCNA
—librenms/librenms (Packagist)before 24.9.024.9.0Patch availableGHSA-x8gm-j36p-fppf
  • librenms Vendorlibrenms Affected before 24.9.0 Fixed in 24.9.0 Patch available CNA
  • librenms/librenms (Packagist) Vendor— Affected before 24.9.0 Fixed in 24.9.0 Patch available GHSA-x8gm-j36p-fppf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*before 24.9.0Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:* Versions before 24.9.0 Vulnerable ·librenms

Remediation

  • Fix · CNA librenms (librenms) Fixed in 24.9.0
  • Fix · GHSA-x8gm-j36p-fppf librenms/librenms (Packagist) Fixed in 24.9.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-47528
  2. 2026-10-03 Alias added: GHSA-x8gm-j36p-fppf

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources