LibreNMS has a stored XSS in ExamplePlugin with Device's Notes
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. User with Admin role can add Notes to a device, the application did not properly sanitize the user input, when the ExamplePlugin enable, if java script code is inside the device's Notes, its will be trigger. This vulnerability is fixed in 24.10.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 24.10.0 | 24.10.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 24.10.0 | 24.10.0 | Patch available | GHSA-c86q-rj37-8f85 |
- librenms Vendorlibrenms Affected before 24.10.0 Fixed in 24.10.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 24.10.0 Fixed in 24.10.0 Patch available GHSA-c86q-rj37-8f85
Remediation
- Fix · CNA librenms (librenms) Fixed in 24.10.0
- Fix · GHSA-c86q-rj37-8f85 librenms/librenms (Packagist) Fixed in 24.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-49758
- 2026-10-03 Alias added: GHSA-c86q-rj37-8f85
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-49758 · CVE Program
- CVE-2024-49758 · NVD
- FIRST EPSS
- GHSA-c86q-rj37-8f85 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences