Read the docs
TI-2024-37137 Aliases CVE-2024-56144GHSA-2f4w-6mc7-4w78

Stored XSS-LibreNMS-Display Name 2 in librenms

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameters (Replace $DEVICE_ID with your specific $DEVICE_ID value):`/device/$DEVICE_ID/edit` -> param: display. Librenms versions up to 24.11.0 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.12.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00396 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms (librenms): 24.12.0librenms/librenms (Packagist): 24.12.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
librenmslibrenmsbefore 24.12.024.12.0Patch availableCNA
—librenms/librenms (Packagist)24.11.10 to before 24.12.024.12.0Patch availableGHSA-2f4w-6mc7-4w78
  • librenms Vendorlibrenms Affected before 24.12.0 Fixed in 24.12.0 Patch available CNA
  • librenms/librenms (Packagist) Vendor— Affected 24.11.10 to before 24.12.0 Fixed in 24.12.0 Patch available GHSA-2f4w-6mc7-4w78

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*before 24.12.0Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:* Versions before 24.12.0 Vulnerable ·librenms

Remediation

  • Fix · CNA librenms (librenms) Fixed in 24.12.0
  • Fix · GHSA-2f4w-6mc7-4w78 librenms/librenms (Packagist) Fixed in 24.12.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-56144
  2. 2026-10-03 Alias added: GHSA-2f4w-6mc7-4w78

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources