WP RealEstate <= 1.6.26 - Unauthenticated Privilege Escalation via 'process_register'
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
The WP RealEstate plugin for WordPress, used by the Homeo theme, is vulnerable to privilege escalation in all versions up to, and including, 1.6.26. This is due to insufficient role restrictions in the 'process_register' function. This makes it possible for unauthenticated attackers to register an account with the Administrator role.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ApusThemes | WP RealEstate | up to 1.6.26 | — | No fix listed | CNA |
- WP RealEstate VendorApusThemes Affected up to 1.6.26 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2237
- 2026-10-03 Alias added: GHSA-2g49-fr8w-j923
References
More ApusThemes vulnerabilities
- TI-2022-03761 Superio - Job Board < 1.2.33 - Subscriber+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2023-00428 WP Private Message < 1.0.6 - Private Message Disclosure via IDOR CVSS 3.1MEDIUM 4.3
- TI-2024-11327 WP Job Board Pro < 1.2.85 - Unauthenticated Privilege Escalation via process_register CVSS 3.1CRITICAL 9.8
- TI-2024-11406 Apus Framework <= 2.4 - Authenticated (Subscriber+) Arbitrary Options Update in import_page_options CVSS 3.1HIGH 8.8
- TI-2022-01056 CareerUp < 2.3.1 - Unauthenticated Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2025-2237 · CVE Program
- CVE-2025-2237 · NVD
- FIRST EPSS
- GHSA-2g49-fr8w-j923 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences