Layout Builder Advanced Permissions - Moderately critical - Access bypass - SA-CONTRIB-2025-097
Priority LOW 20CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.
Summary
Missing Authorization vulnerability in Drupal Layout Builder Advanced Permissions allows Forceful Browsing.This issue affects Layout Builder Advanced Permissions: from 0.0.0 before 2.2.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00263 18th percentileScored 2026-11-07
Fix Fixed Layout Builder Advanced Permissions (Drupal): 2.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Layout Builder Advanced Permissions | 0.0.0 to before 2.2.0 | 2.2.0 | Patch available | CNA |
- Layout Builder Advanced Permissions VendorDrupal Affected 0.0.0 to before 2.2.0 Fixed in 2.2.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:layout_builder_advanced_permissions_project:layout_builder_advanced_permissions:*:*:*:*:*:drupal:*:* | before 2.2.0 | Vulnerable | Layout Builder Advanced Permissions Project |
- cpe:2.3:a:layout_builder_advanced_permissions_project:layout_builder_advanced_permissions:*:*:*:*:*:drupal:*:* Versions before 2.2.0 Vulnerable ·Layout Builder Advanced Permissions Project
Remediation
- Fix · CNA Layout Builder Advanced Permissions (Drupal) Fixed in 2.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-8996
- 2026-10-03 Alias added: GHSA-3wq4-8fhv-h6wv
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-8996 · CVE Program
- CVE-2025-8996 · NVD
- FIRST EPSS
- GHSA-3wq4-8fhv-h6wv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences