Facets - Moderately critical - Information Disclosure - SA-CONTRIB-2025-099
Priority LOW 28CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.
Summary
Missing Authorization vulnerability in Drupal Facets allows Forceful Browsing.This issue affects Facets: from 0.0.0 before 2.0.10, from 3.0.0 before 3.0.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00203 10th percentileScored 2026-11-07
Fix Fixed Facets (Drupal): 2.0.10, 3.0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Facets | 0.0.0 to before 2.0.10; 3.0.0 to before 3.0.1 | 2.0.10, 3.0.1 | Patch available | CNA |
- Facets VendorDrupal Affected 0.0.0 to before 2.0.10; 3.0.0 to before 3.0.1 Fixed in 2.0.10, 3.0.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:facets_project:facets:*:*:*:*:*:drupal:*:* | before 2.0.10; 3.0.0 to before 3.0.1 | Vulnerable | Facets Project |
- cpe:2.3:a:facets_project:facets:*:*:*:*:*:drupal:*:* Versions before 2.0.10; 3.0.0 to before 3.0.1 Vulnerable ·Facets Project
Remediation
- Fix · CNA Facets (Drupal) Fixed in 2.0.10, 3.0.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Facets 2.0.10, 3.0.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-08746 Facets - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-100Priority LOW 27
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9549
- 2026-10-03 Alias added: GHSA-q59x-44mh-c286
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-9549 · CVE Program
- CVE-2025-9549 · NVD
- FIRST EPSS
- GHSA-q59x-44mh-c286 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences