Protected Pages - Moderately critical - Access bypass - SA-CONTRIB-2025-101
Priority LOW 29CWE-307Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-307.
Summary
Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Protected Pages allows Brute Force.This issue affects Protected Pages: from 0.0.0 before 1.8.0, from 7.X-1.0 before 7.X-2.5.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0037 31st percentileScored 2026-11-07
Fix Fixed Protected Pages (Drupal): 1.8.0, 7.x-2.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Protected Pages | 0.0.0 to before 1.8.0; 7.x-1.0 to before 7.x-2.5 | 1.8.0, 7.x-2.5 | Patch available | CNA |
- Protected Pages VendorDrupal Affected 0.0.0 to before 1.8.0; 7.x-1.0 to before 7.x-2.5 Fixed in 1.8.0, 7.x-2.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:protected_pages_project:protected_pages:*:*:*:*:*:drupal:*:* | before 8.x-1.8 | Vulnerable | Protected Pages Project |
- cpe:2.3:a:protected_pages_project:protected_pages:*:*:*:*:*:drupal:*:* Versions before 8.x-1.8 Vulnerable ·Protected Pages Project
Remediation
- Fix · CNA Protected Pages (Drupal) Fixed in 1.8.0, 7.x-2.5
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9551
- 2026-10-03 Alias added: GHSA-c25q-57mr-rv37
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-9551 · CVE Program
- CVE-2025-9551 · NVD
- FIRST EPSS
- GHSA-c25q-57mr-rv37 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences