Read the docs
TI-2025-09058 Aliases CVE-2025-9873GHSA-4xf7-pj4h-4vjp

a3 Lazy Load <= 2.7.5 - Authenticated (Contributor+) Stored Cross-Site Scripting

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The a3 Lazy Load plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.7.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00289 21st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
a3reva3 Lazy Loadup to 2.7.5—No fix listedCNA
  • a3 Lazy Load Vendora3rev Affected up to 2.7.5 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-9873
  2. 2026-10-03 Alias added: GHSA-4xf7-pj4h-4vjp

References

  • TI-2023-00091 Page View Count < 2.6.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2022-00358 Page Views Count < 2.4.15 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-11423 Compare Products for WooCommerce <= 3.2.1 - Unauthenticated PHP Object Injection CVSS 3.1HIGH 8.1
  • TI-2025-02460 Page View Count 2.8.0 - 2.8.4 - Missing Authorization to Authenticated (Subscriber+) Limited Options Update CVSS 3.1HIGH 8.1
  • TI-2024-01683 Product Sort and Display for WooCommerce <= 2.4.1 - Missing Authorization CVSS 3.1MEDIUM 6.5
  • TI-2024-25904 WordPress Predictive Search for WooCommerce plugin <= 6.0.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
See all 15 →

Sources