Read the docs
TI-2025-10008 Aliases CVE-2025-10930GHSA-27fv-rpgj-4c6m

Currency - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-110

Priority LOW 34CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Currency allows Cross Site Request Forgery.This issue affects Currency: from 0.0.0 before 3.5.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00133 2nd percentileScored 2026-11-07
Fix Fixed Currency (Drupal): 3.5.0drupal/currency (Packagist): 3.5.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalCurrency0.0.0 to before 3.5.03.5.0Patch availableCNA
—drupal/currency (Packagist)before 3.5.03.5.0Patch availableGHSA-27fv-rpgj-4c6m
  • Currency VendorDrupal Affected 0.0.0 to before 3.5.0 Fixed in 3.5.0 Patch available CNA
  • drupal/currency (Packagist) Vendor— Affected before 3.5.0 Fixed in 3.5.0 Patch available GHSA-27fv-rpgj-4c6m

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:2bits:currency:*:*:*:*:*:drupal:*:*before 8.x-3.5Vulnerable2bits
  • cpe:2.3:a:2bits:currency:*:*:*:*:*:drupal:*:* Versions before 8.x-3.5 Vulnerable ·2bits

Remediation

  • Fix · CNA Currency (Drupal) Fixed in 3.5.0
  • Fix · GHSA-27fv-rpgj-4c6m drupal/currency (Packagist) Fixed in 3.5.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-10930
  2. 2026-10-03 Alias added: GHSA-27fv-rpgj-4c6m

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources