Umami Analytics - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-109
Priority LOW 17CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Umami Analytics allows Cross-Site Scripting (XSS).This issue affects Umami Analytics: from 0.0.0 before 1.0.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00201 10th percentileScored 2026-11-07
Fix Fixed Umami Analytics (Drupal): 1.0.1drupal/umami_analytics (Packagist): 1.0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Umami Analytics | 0.0.0 to before 1.0.1 | 1.0.1 | Patch available | CNA |
| — | drupal/umami_analytics (Packagist) | before 1.0.1 | 1.0.1 | Patch available | GHSA-jxp8-4jw5-5xjc |
- Umami Analytics VendorDrupal Affected 0.0.0 to before 1.0.1 Fixed in 1.0.1 Patch available CNA
- drupal/umami_analytics (Packagist) Vendor— Affected before 1.0.1 Fixed in 1.0.1 Patch available GHSA-jxp8-4jw5-5xjc
Remediation
- Fix · CNA Umami Analytics (Drupal) Fixed in 1.0.1
- Fix · GHSA-jxp8-4jw5-5xjc drupal/umami_analytics (Packagist) Fixed in 1.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-10931
- 2026-10-03 Alias added: GHSA-jxp8-4jw5-5xjc
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-10931 · CVE Program
- CVE-2025-10931 · NVD
- FIRST EPSS
- GHSA-jxp8-4jw5-5xjc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences