Read the docs
TI-2025-11695 Aliases CVE-2025-12761GHSA-gg35-374m-9ph8

Simple multi step form - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-116

Priority LOW 16CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Simple multi step form allows Cross-Site Scripting (XSS).This issue affects Simple multi step form: from 0.0.0 before 2.0.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00186 8th percentileScored 2026-11-07
Fix Fixed Simple multi step form (Drupal): 2.0.0drupal/simple_multistep (Packagist): 2.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalSimple multi step form0.0.0 to before 2.0.02.0.0Patch availableCNA
—drupal/simple_multistep (Packagist)before 2.0.02.0.0Patch availableGHSA-gg35-374m-9ph8
  • Simple multi step form VendorDrupal Affected 0.0.0 to before 2.0.0 Fixed in 2.0.0 Patch available CNA
  • drupal/simple_multistep (Packagist) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-gg35-374m-9ph8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:simple_multi_step_form_project:simple_multi_step_form:*:*:*:*:*:drupal:*:*before 2.0.0VulnerableSimple Multi Step Form Project
  • cpe:2.3:a:simple_multi_step_form_project:simple_multi_step_form:*:*:*:*:*:drupal:*:* Versions before 2.0.0 Vulnerable ·Simple Multi Step Form Project

Remediation

  • Fix · CNA Simple multi step form (Drupal) Fixed in 2.0.0
  • Fix · GHSA-gg35-374m-9ph8 drupal/simple_multistep (Packagist) Fixed in 2.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-12761
  2. 2026-10-03 Alias added: GHSA-gg35-374m-9ph8

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources