CKEditor 5 Premium Features - Moderately critical - Access bypass - SA-CONTRIB-2025-118
Priority LOW 30CWE-288Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-288.
Summary
Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal CKEditor 5 Premium Features allows Functionality Bypass.This issue affects CKEditor 5 Premium Features: from 0.0.0 before 1.2.10, from 1.3.0 before 1.3.6, from 1.4.0 before 1.4.3, from 1.5.0 before 1.5.1, from 1.6.0 before 1.6.4.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00269 19th percentileScored 2026-11-07
Fix Fixed CKEditor 5 Premium Features (Drupal): 1.2.10, 1.3.6, 1.4.3 +2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | CKEditor 5 Premium Features | 0.0.0 to before 1.2.10; 1.3.0 to before 1.3.6; 1.4.0 to before 1.4.3; 1.5.0 to before 1.5.1; 1.6.0 to before 1.6.4 | 1.2.10, 1.3.6, 1.4.3, 1.5.1, 1.6.4 | Patch available | CNA |
- CKEditor 5 Premium Features VendorDrupal Affected 0.0.0 to before 1.2.10; 1.3.0 to before 1.3.6; 1.4.0 to before 1.4.3; 1.5.0 to before 1.5.1; 1.6.0 to before 1.6.4 Fixed in 1.2.10, 1.3.6, 1.4.3, 1.5.1, 1.6.4 Patch available CNA
CPE configurations NVD · 2
Remediation
- Fix · CNA CKEditor 5 Premium Features (Drupal) Fixed in 1.2.10, 1.3.6, 1.4.3, 1.5.1, 1.6.4
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13980
- 2026-10-03 Alias added: GHSA-8479-rrmq-2rhw
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-13980 · CVE Program
- CVE-2025-13980 · NVD
- FIRST EPSS
- GHSA-8479-rrmq-2rhw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences