WooCommerce - Subscriber/Customer+ Order Data Disclosure
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-200.
Summary
A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Automattic | WooCommerce | 8.1.0 to before 8.1.3; 8.2.0 to before 8.2.4; 8.3.0 to before 8.3.3; 8.4.0 to before 8.4.2; 8.5.0 to before 8.5.4; 8.6.0 to before 8.6.3; 8.7.0 to before 8.7.2; 8.8.0 to before 8.8.6; 8.9.0 to before 8.9.4; 9.0.0 to before 9.0.3; 9.1.0 to before 9.1.5; 9.2.0 to before 9.2.4; 9.3.0 to before 9.3.5; 9.4.0 to before 9.4.4; 9.5.0 to before 9.5.3; 9.6.0 to before 9.6.3; 9.7.0 to before 9.7.2; 9.8.0 to before 9.8.6; 9.9.0 to before 9.9.6; 10.0.0 to before 10.0.5; 10.1.0 to before 10.1.3; 10.2.0 to before 10.2.3; 10.3.0 to before 10.3.7; 10.4.0 to before 10.4.3 | 8.1.3, 8.2.4, 8.3.3, 8.4.2, 8.5.4, 8.6.3, 8.7.2, 8.8.6, 8.9.4, 9.0.3, 9.1.5, 9.2.4, 9.3.5, 9.4.4, 9.5.3, 9.6.3, 9.7.2, 9.8.6, 9.9.6, 10.0.5, 10.1.3, 10.2.3, 10.3.7, 10.4.3 | Patch available | CNA |
- WooCommerce VendorAutomattic Affected 8.1.0 to before 8.1.3; 8.2.0 to before 8.2.4; 8.3.0 to before 8.3.3; 8.4.0 to before 8.4.2; 8.5.0 to before 8.5.4; 8.6.0 to before 8.6.3; 8.7.0 to before 8.7.2; 8.8.0 to before 8.8.6; 8.9.0 to before 8.9.4; 9.0.0 to before 9.0.3; 9.1.0 to before 9.1.5; 9.2.0 to before 9.2.4; 9.3.0 to before 9.3.5; 9.4.0 to before 9.4.4; 9.5.0 to before 9.5.3; 9.6.0 to before 9.6.3; 9.7.0 to before 9.7.2; 9.8.0 to before 9.8.6; 9.9.0 to before 9.9.6; 10.0.0 to before 10.0.5; 10.1.0 to before 10.1.3; 10.2.0 to before 10.2.3; 10.3.0 to before 10.3.7; 10.4.0 to before 10.4.3 Fixed in 8.1.3, 8.2.4, 8.3.3, 8.4.2, 8.5.4, 8.6.3, 8.7.2, 8.8.6, 8.9.4, 9.0.3, 9.1.5, 9.2.4, 9.3.5, 9.4.4, 9.5.3, 9.6.3, 9.7.2, 9.8.6, 9.9.6, 10.0.5, 10.1.3, 10.2.3, 10.3.7, 10.4.3 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:*:*:* | — | — | WooCommerce |
- cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:*:*:* Versions — — ·WooCommerce
Remediation
- Fix · CNA WooCommerce (Automattic) Fixed in 8.1.3, 8.2.4, 8.3.3, 8.4.2, 8.5.4, 8.6.3, 8.7.2, 8.8.6, 8.9.4, 9.0.3, 9.1.5, 9.2.4, 9.3.5, 9.4.4, 9.5.3, 9.6.3, 9.7.2, 9.8.6, 9.9.6, 10.0.5, 10.1.3, 10.2.3, 10.3.7, 10.4.3
Timeline
- 2026-10-02 Threatist record created from CVE-2025-15033
- 2026-10-03 Alias added: GHSA-q45j-x3cj-gjvq
References
More Automattic vulnerabilities
- TI-2023-12700 Improper authentication in WooCommerce Payments WordPress Plugin CVSS 3.1CRITICAL 9.8
- TI-2023-03453 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2024-06106 Jetpack Boost < 3.4.7 - Admin+ SSRF CVSS 3.1CRITICAL 9.1
- TI-2013-01782 WordPress W3 Total Cache Plugin 0.9.2.8 has a Remote PHP Code Execution Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-02368 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2023-02806 Jetpack < 12.1.1 - Author+ Arbitrary File Manipulation via API CVSS 3.1HIGH 8.8
Sources
- CVE-2025-15033 · CVE Program
- CVE-2025-15033 · NVD
- FIRST EPSS
- GHSA-q45j-x3cj-gjvq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences