Read the docs
TI-2025-16985 Aliases CVE-2025-23200GHSA-c66p-64fj-jmc2

Stored XSS-LibreNMS-Misc Section in librenms

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameter: `ajax_form.php` -> param: state. Librenms versions up to 24.10.1 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.11.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.49322 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms (librenms): 24.11.0librenms/librenms (Packagist): 24.11.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
librenmslibrenmsbefore 24.11.024.11.0Patch availableCNA
—librenms/librenms (Packagist)23.9.0 to before 24.11.024.11.0Patch availableGHSA-c66p-64fj-jmc2
  • librenms Vendorlibrenms Affected before 24.11.0 Fixed in 24.11.0 Patch available CNA
  • librenms/librenms (Packagist) Vendor— Affected 23.9.0 to before 24.11.0 Fixed in 24.11.0 Patch available GHSA-c66p-64fj-jmc2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*before 24.11.0Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:* Versions before 24.11.0 Vulnerable ·librenms

Remediation

  • Fix · CNA librenms (librenms) Fixed in 24.11.0
  • Fix · GHSA-c66p-64fj-jmc2 librenms/librenms (Packagist) Fixed in 24.11.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-23200
  2. 2026-10-03 Alias added: GHSA-c66p-64fj-jmc2

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources