Read the docs
TI-2025-16995 Aliases CVE-2025-23210GHSA-r57h-547h-w24f

Bypass XSS sanitizer using the javascript protocol and special characters in phpoffice/phpspreadsheet

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

phpoffice/phpspreadsheet is a pure PHP library for reading and writing spreadsheet files. Affected versions have been found to have a Bypass of the Cross-site Scripting (XSS) sanitizer using the javascript protocol and special characters. This issue has been addressed in versions 3.9.0, 2.3.7, 2.1.8, and 1.29.9. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00415 36th percentileScored 2026-11-07
Fix Fixed PhpSpreadsheet (PHPOffice): 3.9.0, 2.3.7, 2.1.8 +1phpoffice/phpspreadsheet (Packagist): 3.9.0, 1.29.9, 2.3.7 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHPOfficePhpSpreadsheet3.0.0 to before 3.9.0; 2.2.0 to before 2.3.7; 2.0.0 to before 2.1.8; before 1.29.93.9.0, 2.3.7, 2.1.8, 1.29.9Patch availableCNA
—phpoffice/phpspreadsheet (Packagist)3.0.0 to before 3.9.03.9.0Patch availableGHSA-r57h-547h-w24f
—phpoffice/phpspreadsheet (Packagist)before 1.29.91.29.9Patch availableGHSA-r57h-547h-w24f
—phpoffice/phpspreadsheet (Packagist)2.2.0 to before 2.3.72.3.7Patch availableGHSA-r57h-547h-w24f
—phpoffice/phpspreadsheet (Packagist)2.0.0 to before 2.1.82.1.8Patch availableGHSA-r57h-547h-w24f
—phpoffice/phpexcel (Packagist)up to 1.8.2—No fix listedGHSA-r57h-547h-w24f
  • PhpSpreadsheet VendorPHPOffice Affected 3.0.0 to before 3.9.0; 2.2.0 to before 2.3.7; 2.0.0 to before 2.1.8; before 1.29.9 Fixed in 3.9.0, 2.3.7, 2.1.8, 1.29.9 Patch available CNA
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 3.0.0 to before 3.9.0 Fixed in 3.9.0 Patch available GHSA-r57h-547h-w24f
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.29.9 Fixed in 1.29.9 Patch available GHSA-r57h-547h-w24f
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.3.7 Fixed in 2.3.7 Patch available GHSA-r57h-547h-w24f
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.8 Fixed in 2.1.8 Patch available GHSA-r57h-547h-w24f
  • phpoffice/phpexcel (Packagist) Vendor— Affected up to 1.8.2 Fixed in — No fix listed GHSA-r57h-547h-w24f

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*——PHPOffice
  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* Versions — — ·PHPOffice

Remediation

  • Fix · CNA PhpSpreadsheet (PHPOffice) Fixed in 3.9.0, 2.3.7, 2.1.8, 1.29.9
  • Fix · GHSA-r57h-547h-w24f phpoffice/phpspreadsheet (Packagist) Fixed in 3.9.0 Advisory →
  • Fix · GHSA-r57h-547h-w24f phpoffice/phpspreadsheet (Packagist) Fixed in 1.29.9 Advisory →
  • Fix · GHSA-r57h-547h-w24f phpoffice/phpspreadsheet (Packagist) Fixed in 2.3.7 Advisory →
  • Fix · GHSA-r57h-547h-w24f phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-23210
  2. 2026-10-03 Alias added: GHSA-r57h-547h-w24f

References

  • TI-2026-32885 PhpSpreadsheet: File::prohibitWrappers bypass CVSS 4.0CRITICAL 9.2
  • TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
  • TI-2026-79412 PhpSpreadsheet ODS reader exhausts CPU and memory via repeated rows CVSS 4.0HIGH 8.7
  • TI-2025-34182 PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser CVSS 4.0HIGH 8.7
  • TI-2026-78784 Insecure deserialization in PHPOffice PHPPresentation allows code execution CVSS 4.0CRITICAL 9.2
  • TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
See all 37 →

Sources