Read the docs
TI-2025-21010 Aliases CVE-2025-29192GHSA-7r4h-vmj9-wg42

Flowise before 3.0.5 allows XSS via a FORM element and an INPUT element when an admin views the chat log.

Priority HIGH 69CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Flowise before 3.0.5 allows XSS via a FORM element and an INPUT element when an admin views the chat log.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0041 35th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Flowise (FlowiseAI): 3.0.5flowise (npm): 3.0.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
FlowiseAIFlowisebefore 3.0.53.0.5Patch availableCNA
—flowise (npm)before 3.0.53.0.5Patch availableGHSA-7r4h-vmj9-wg42
  • Flowise VendorFlowiseAI Affected before 3.0.5 Fixed in 3.0.5 Patch available CNA
  • flowise (npm) Vendor— Affected before 3.0.5 Fixed in 3.0.5 Patch available GHSA-7r4h-vmj9-wg42

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*before 3.0.5VulnerableFlowiseAI
  • cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:* Versions before 3.0.5 Vulnerable ·FlowiseAI

Remediation

  • Fix · CNA Flowise (FlowiseAI) Fixed in 3.0.5
  • Fix · GHSA-7r4h-vmj9-wg42 flowise (npm) Fixed in 3.0.5 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    FlowiseAI Flowise 3.0.5

    2 records Highest priority Priority HIGH 2 HIGH

    Other records, highest priority first

    • TI-2025-32162 Flowise before 3.0.5 allows XSS via an IFRAME element when an admin views the chat log.Priority HIGH 69

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-29192
  2. 2026-10-03 Alias added: GHSA-7r4h-vmj9-wg42

References

  • TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
  • TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
  • TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
  • TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
  • TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
See all 127 →

Sources