Flowise before 3.0.5 allows XSS via an IFRAME element when an admin views the chat log.
Priority HIGH 69CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Flowise before 3.0.5 allows XSS via an IFRAME element when an admin views the chat log.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.14712 96th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Flowise (FlowiseAI): 3.0.5flowise (npm): 3.0.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| FlowiseAI | Flowise | before 3.0.5 | 3.0.5 | Patch available | CNA |
| — | flowise (npm) | before 3.0.8 | 3.0.8 | Patch available | GHSA-964p-j4gg-mhwc |
- Flowise VendorFlowiseAI Affected before 3.0.5 Fixed in 3.0.5 Patch available CNA
- flowise (npm) Vendor— Affected before 3.0.8 Fixed in 3.0.8 Patch available GHSA-964p-j4gg-mhwc
Remediation
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.0.5
- Fix · GHSA-964p-j4gg-mhwc flowise (npm) Fixed in 3.0.8 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
FlowiseAI Flowise 3.0.5
2 records Highest priority Priority HIGH 2 HIGH
Other records, highest priority first
- TI-2025-21010 Flowise before 3.0.5 allows XSS via a FORM element and an INPUT element when an admin views the chat log.Priority HIGH 69
Timeline
- 2026-10-02 Threatist record created from CVE-2025-50538
- 2026-10-03 Alias added: GHSA-964p-j4gg-mhwc
References
More FlowiseAI Flowise vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
- TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
Sources
- CVE-2025-50538 · CVE Program
- CVE-2025-50538 · NVD
- FIRST EPSS
- GHSA-964p-j4gg-mhwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences