Contao allows cross-site scripting through SVG uploads
Priority LOW 21CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Contao is an Open Source CMS. Users can upload SVG files with malicious code, which is then executed in the back end and/or front end. This vulnerability is fixed in Contao 4.13.54, 5.3.30, or 5.5.6.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00225 13th percentileScored 2026-11-07
Fix Fixed contao (contao): 4.13.54, 5.3.30, 5.5.6contao/core-bundle (Packagist): 4.13.54, 5.3.30, 5.5.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| contao | contao | 4.0.0 to before 4.13.54; 5.0.0 to before 5.3.30; 5.4.0 to before 5.5.6 | 4.13.54, 5.3.30, 5.5.6 | Patch available | CNA |
| — | contao/core-bundle (Packagist) | 4.0.0 to before 4.13.54 | 4.13.54 | Patch available | GHSA-vqqr-fgmh-f626 |
| — | contao/core-bundle (Packagist) | 5.3.0 to before 5.3.30 | 5.3.30 | Patch available | GHSA-vqqr-fgmh-f626 |
| — | contao/core-bundle (Packagist) | 5.4.0 to before 5.5.6 | 5.5.6 | Patch available | GHSA-vqqr-fgmh-f626 |
- contao Vendorcontao Affected 4.0.0 to before 4.13.54; 5.0.0 to before 5.3.30; 5.4.0 to before 5.5.6 Fixed in 4.13.54, 5.3.30, 5.5.6 Patch available CNA
- contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.13.54 Fixed in 4.13.54 Patch available GHSA-vqqr-fgmh-f626
- contao/core-bundle (Packagist) Vendor— Affected 5.3.0 to before 5.3.30 Fixed in 5.3.30 Patch available GHSA-vqqr-fgmh-f626
- contao/core-bundle (Packagist) Vendor— Affected 5.4.0 to before 5.5.6 Fixed in 5.5.6 Patch available GHSA-vqqr-fgmh-f626
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* | 4.0.0 to before 4.13.53; 5.0.0 to before 5.3.30; 5.4.0 to before 5.5.6 | Vulnerable | contao |
- cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.13.53; 5.0.0 to before 5.3.30; 5.4.0 to before 5.5.6 Vulnerable ·contao
Remediation
- Fix · CNA contao (contao) Fixed in 4.13.54, 5.3.30, 5.5.6
- Fix · GHSA-vqqr-fgmh-f626 contao/core-bundle (Packagist) Fixed in 4.13.54 Advisory →
- Fix · GHSA-vqqr-fgmh-f626 contao/core-bundle (Packagist) Fixed in 5.3.30 Advisory →
- Fix · GHSA-vqqr-fgmh-f626 contao/core-bundle (Packagist) Fixed in 5.5.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-29790
- 2026-10-03 Alias added: GHSA-vqqr-fgmh-f626
References
More Contao vulnerabilities
- TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
- TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
- TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
- TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
- TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
Sources
- CVE-2025-29790 · CVE Program
- CVE-2025-29790 · NVD
- FIRST EPSS
- GHSA-vqqr-fgmh-f626 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences