Read the docs
TI-2025-22821 Aliases CVE-2025-31677GHSA-9w85-x5hg-fr66

AI (Artificial Intelligence) - Critical - Cross Site Request Forgery - SA-CONTRIB-2025-003

Priority LOW 39CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Cross-Site Request Forgery (CSRF) vulnerability in Drupal AI (Artificial Intelligence) allows Cross Site Request Forgery.This issue affects AI (Artificial Intelligence): from 1.0.0 before 1.0.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00227 13th percentileScored 2026-11-07
Fix Fixed AI (Artificial Intelligence) (Drupal): 1.0.2drupal/ai (Packagist): 1.0.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalAI (Artificial Intelligence)1.0.0 to before 1.0.21.0.2Patch availableCNA
—drupal/ai (Packagist)1.0.0 to before 1.0.21.0.2Patch availableGHSA-9w85-x5hg-fr66
  • AI (Artificial Intelligence) VendorDrupal Affected 1.0.0 to before 1.0.2 Fixed in 1.0.2 Patch available CNA
  • drupal/ai (Packagist) Vendor— Affected 1.0.0 to before 1.0.2 Fixed in 1.0.2 Patch available GHSA-9w85-x5hg-fr66

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:artificial_intelligence_project:artificial_intelligence:*:*:*:*:*:drupal:*:*1.0.0 to before 1.0.2VulnerableArtificial Intelligence Project
  • cpe:2.3:a:artificial_intelligence_project:artificial_intelligence:*:*:*:*:*:drupal:*:* Versions 1.0.0 to before 1.0.2 Vulnerable ·Artificial Intelligence Project

Remediation

  • Fix · CNA AI (Artificial Intelligence) (Drupal) Fixed in 1.0.2
  • Fix · GHSA-9w85-x5hg-fr66 drupal/ai (Packagist) Fixed in 1.0.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-31677
  2. 2026-10-03 Alias added: GHSA-9w85-x5hg-fr66

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources