Read the docs
TI-2025-22823 Aliases CVE-2025-31679GHSA-rhxm-r44m-4325

Ignition Error Pages - Critical - Cross Site Scripting - SA-CONTRIB-2025-007

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Ignition Error Pages allows Cross-Site Scripting (XSS).This issue affects Ignition Error Pages: from 0.0.0 before 1.0.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00262 18th percentileScored 2026-11-07
Fix Fixed Ignition Error Pages (Drupal): 1.0.4drupal/ignition (Packagist): 1.0.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalIgnition Error Pages0.0.0 to before 1.0.41.0.4Patch availableCNA
—drupal/ignition (Packagist)before 1.0.41.0.4Patch availableGHSA-rhxm-r44m-4325
  • Ignition Error Pages VendorDrupal Affected 0.0.0 to before 1.0.4 Fixed in 1.0.4 Patch available CNA
  • drupal/ignition (Packagist) Vendor— Affected before 1.0.4 Fixed in 1.0.4 Patch available GHSA-rhxm-r44m-4325

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ignition_error_pages_project:ignition_error_pages:*:*:*:*:*:drupal:*:*before 1.0.4VulnerableIgnition Error Pages Project
  • cpe:2.3:a:ignition_error_pages_project:ignition_error_pages:*:*:*:*:*:drupal:*:* Versions before 1.0.4 Vulnerable ·Ignition Error Pages Project

Remediation

  • Fix · CNA Ignition Error Pages (Drupal) Fixed in 1.0.4
  • Fix · GHSA-rhxm-r44m-4325 drupal/ignition (Packagist) Fixed in 1.0.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-31679
  2. 2026-10-03 Alias added: GHSA-rhxm-r44m-4325

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources