Google Tag - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-012
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Google Tag allows Cross Site Request Forgery.This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Google Tag | 0.0.0 to before 1.8.0; 2.0.0 to before 2.0.8 | 1.8.0, 2.0.8 | Patch available | CNA |
| — | drupal/google_tag (Packagist) | before 1.8.0 | 1.8.0 | Patch available | GHSA-qchr-8m24-7v66 |
| — | drupal/google_tag (Packagist) | 2.0.0 to before 2.0.8 | 2.0.8 | Patch available | GHSA-qchr-8m24-7v66 |
- Google Tag VendorDrupal Affected 0.0.0 to before 1.8.0; 2.0.0 to before 2.0.8 Fixed in 1.8.0, 2.0.8 Patch available CNA
- drupal/google_tag (Packagist) Vendor— Affected before 1.8.0 Fixed in 1.8.0 Patch available GHSA-qchr-8m24-7v66
- drupal/google_tag (Packagist) Vendor— Affected 2.0.0 to before 2.0.8 Fixed in 2.0.8 Patch available GHSA-qchr-8m24-7v66
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google_tag_project:google_tag:*:*:*:*:*:drupal:*:* | 7.x-1.0 to before 8.x-1.8; 2.0.0 to before 2.0.8 | Vulnerable | Google Tag Project |
- cpe:2.3:a:google_tag_project:google_tag:*:*:*:*:*:drupal:*:* Versions 7.x-1.0 to before 8.x-1.8; 2.0.0 to before 2.0.8 Vulnerable ·Google Tag Project
Remediation
- Fix · CNA Google Tag (Drupal) Fixed in 1.8.0, 2.0.8
- Fix · GHSA-qchr-8m24-7v66 drupal/google_tag (Packagist) Fixed in 1.8.0 Advisory →
- Fix · GHSA-qchr-8m24-7v66 drupal/google_tag (Packagist) Fixed in 2.0.8 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Google Tag 1.8.0, 2.0.8
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-22826 Google Tag - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-011Priority LOW 22
Timeline
- 2026-10-02 Threatist record created from CVE-2025-31683
- 2026-10-03 Alias added: GHSA-qchr-8m24-7v66
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-31683 · CVE Program
- CVE-2025-31683 · NVD
- FIRST EPSS
- GHSA-qchr-8m24-7v66 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences