General Data Protection Regulation - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-018
Priority LOW 35CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) vulnerability in Drupal General Data Protection Regulation allows Cross Site Request Forgery.This issue affects General Data Protection Regulation: from 0.0.0 before 3.0.1, from 3.1.0 before 3.1.2.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00208 11th percentileScored 2026-11-07
Fix Fixed General Data Protection Regulation (Drupal): 3.0.1, 3.1.2drupal/gdpr (Packagist): 3.0.1, 3.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | General Data Protection Regulation | 0.0.0 to before 3.0.1; 3.1.0 to before 3.1.2 | 3.0.1, 3.1.2 | Patch available | CNA |
| — | drupal/gdpr (Packagist) | before 3.0.1 | 3.0.1 | Patch available | GHSA-jv6r-mj9p-9xff |
| — | drupal/gdpr (Packagist) | 3.1.0 to before 3.1.2 | 3.1.2 | Patch available | GHSA-jv6r-mj9p-9xff |
- General Data Protection Regulation VendorDrupal Affected 0.0.0 to before 3.0.1; 3.1.0 to before 3.1.2 Fixed in 3.0.1, 3.1.2 Patch available CNA
- drupal/gdpr (Packagist) Vendor— Affected before 3.0.1 Fixed in 3.0.1 Patch available GHSA-jv6r-mj9p-9xff
- drupal/gdpr (Packagist) Vendor— Affected 3.1.0 to before 3.1.2 Fixed in 3.1.2 Patch available GHSA-jv6r-mj9p-9xff
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:general_data_protection_regulation_project:general_data_protection_regulation:*:*:*:*:*:drupla:*:* | before 3.0.1; 3.1.0 to before 3.1.2 | Vulnerable | General Data Protection Regulation Project |
- cpe:2.3:a:general_data_protection_regulation_project:general_data_protection_regulation:*:*:*:*:*:drupla:*:* Versions before 3.0.1; 3.1.0 to before 3.1.2 Vulnerable ·General Data Protection Regulation Project
Remediation
- Fix · CNA General Data Protection Regulation (Drupal) Fixed in 3.0.1, 3.1.2
- Fix · GHSA-jv6r-mj9p-9xff drupal/gdpr (Packagist) Fixed in 3.0.1 Advisory →
- Fix · GHSA-jv6r-mj9p-9xff drupal/gdpr (Packagist) Fixed in 3.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-31689
- 2026-10-03 Alias added: GHSA-jv6r-mj9p-9xff
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-31689 · CVE Program
- CVE-2025-31689 · NVD
- FIRST EPSS
- GHSA-jv6r-mj9p-9xff · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences