IFrame Remove Filter - Moderately critical - Cross site scripting - SA-CONTRIB-2025-051
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal IFrame Remove Filter allows Cross-Site Scripting (XSS).This issue affects IFrame Remove Filter: from 2.0.0 before 2.0.5, from 7.X-1.0 through 7.X-1.5, from 1.0 through 1.2.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00281 20th percentileScored 2026-11-07
Fix Fixed IFrame Remove Filter (Drupal): 2.0.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | IFrame Remove Filter | 7.x-1.0 – 7.x-1.5; 1.0 – 1.2; 2.0.0 to before 2.0.5 | 2.0.5 | Patch available | CNA |
- IFrame Remove Filter VendorDrupal Affected 7.x-1.0 – 7.x-1.5; 1.0 – 1.2; 2.0.0 to before 2.0.5 Fixed in 2.0.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:iframe_remove_filter_project:iframe_remove_filter:*:*:*:*:*:drupal:*:* | before 2.0.5; 7.x-1.0 – 8.x-1.2 | Vulnerable | Iframe Remove Filter Project |
- cpe:2.3:a:iframe_remove_filter_project:iframe_remove_filter:*:*:*:*:*:drupal:*:* Versions before 2.0.5; 7.x-1.0 – 8.x-1.2 Vulnerable ·Iframe Remove Filter Project
Remediation
- Fix · CNA IFrame Remove Filter (Drupal) Fixed in 2.0.5
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47705
- 2026-10-03 Alias added: GHSA-v265-mq78-w999
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-47705 · CVE Program
- CVE-2025-47705 · NVD
- FIRST EPSS
- GHSA-v265-mq78-w999 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences