LibreNMS stored Cross-site Scripting vulnerability in poller group name
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LibreNMS is PHP/MySQL/SNMP based network monitoring software. LibreNMS v25.4.0 and prior suffers from a Stored Cross-Site Scripting (XSS) Vulnerability in the `group name` parameter of the `http://localhost/poller/groups` form. This vulnerability allows attackers to inject malicious scripts into web pages viewed by other users. LibreNMS v25.5.0 contains a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 25.5.0 | 25.5.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 25.5.0 | 25.5.0 | Patch available | GHSA-hxw5-9cc5-cmw5 |
- librenms Vendorlibrenms Affected before 25.5.0 Fixed in 25.5.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 25.5.0 Fixed in 25.5.0 Patch available GHSA-hxw5-9cc5-cmw5
Remediation
- Fix · CNA librenms (librenms) Fixed in 25.5.0
- Fix · GHSA-hxw5-9cc5-cmw5 librenms/librenms (Packagist) Fixed in 25.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-47931
- 2026-10-03 Alias added: GHSA-hxw5-9cc5-cmw5
References
Patch 2
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2025-47931 · CVE Program
- CVE-2025-47931 · NVD
- FIRST EPSS
- GHSA-hxw5-9cc5-cmw5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences