Quick Node Block - Moderately critical - Access bypass - SA-CONTRIB-2025-064
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Missing Authorization vulnerability in Drupal Quick Node Block allows Forceful Browsing.This issue affects Quick Node Block: from 0.0.0 before 2.0.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Quick Node Block | 0.0.0 to before 2.0.0 | 2.0.0 | Patch available | CNA |
| — | drupal/quick_node_block (Packagist) | before 2.0.0 | 2.0.0 | Patch available | GHSA-c424-hgg9-9c4w |
- Quick Node Block VendorDrupal Affected 0.0.0 to before 2.0.0 Fixed in 2.0.0 Patch available CNA
- drupal/quick_node_block (Packagist) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-c424-hgg9-9c4w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:quick_node_block_project:quick_node_block:2.0.x:dev:*:*:*:drupal:*:* | 2.0.x dev | Vulnerable | Quick Node Block Project |
- cpe:2.3:a:quick_node_block_project:quick_node_block:2.0.x:dev:*:*:*:drupal:*:* Versions 2.0.x dev Vulnerable ·Quick Node Block Project
Remediation
- Fix · CNA Quick Node Block (Drupal) Fixed in 2.0.0
- Fix · GHSA-c424-hgg9-9c4w drupal/quick_node_block (Packagist) Fixed in 2.0.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Quick Node Block 2.0.0
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-30397 Quick Node Block - Moderately critical - Access bypass - SA-CONTRIB-2025-065Priority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48444
- 2026-10-03 Alias added: GHSA-c424-hgg9-9c4w
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-48444 · CVE Program
- CVE-2025-48444 · NVD
- FIRST EPSS
- GHSA-c424-hgg9-9c4w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences