Lightgallery - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-069
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Lightgallery allows Cross-Site Scripting (XSS).This issue affects Lightgallery: from 0.0.0 before 1.6.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00349 28th percentileScored 2026-11-07
Fix Fixed Lightgallery (Drupal): 1.6.0drupal/lightgallery (Packagist): 1.6.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Lightgallery | 0.0.0 to before 1.6.0 | 1.6.0 | Patch available | CNA |
| — | drupal/lightgallery (Packagist) | before 1.6.0 | 1.6.0 | Patch available | GHSA-w5px-5878-m9x4 |
- Lightgallery VendorDrupal Affected 0.0.0 to before 1.6.0 Fixed in 1.6.0 Patch available CNA
- drupal/lightgallery (Packagist) Vendor— Affected before 1.6.0 Fixed in 1.6.0 Patch available GHSA-w5px-5878-m9x4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lightgallery_project:lightgallery:*:*:*:*:*:drupal:*:* | before 1.6.0 | Vulnerable | Lightgallery Project |
- cpe:2.3:a:lightgallery_project:lightgallery:*:*:*:*:*:drupal:*:* Versions before 1.6.0 Vulnerable ·Lightgallery Project
Remediation
- Fix · CNA Lightgallery (Drupal) Fixed in 1.6.0
- Fix · GHSA-w5px-5878-m9x4 drupal/lightgallery (Packagist) Fixed in 1.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48447
- 2026-10-03 Alias added: GHSA-w5px-5878-m9x4
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-48447 · CVE Program
- CVE-2025-48447 · NVD
- FIRST EPSS
- GHSA-w5px-5878-m9x4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences