EU Cookie Compliance (GDPR Compliance) - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-072
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal EU Cookie Compliance (GDPR Compliance) allows Cross-Site Scripting (XSS).This issue affects EU Cookie Compliance (GDPR Compliance): from 0.0.0 before 1.26.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00224 13th percentileScored 2026-11-07
Fix Fixed EU Cookie Compliance (GDPR Compliance) (Drupal): 1.26.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | EU Cookie Compliance (GDPR Compliance) | 0.0.0 to before 1.26.0 | 1.26.0 | Patch available | CNA |
- EU Cookie Compliance (GDPR Compliance) VendorDrupal Affected 0.0.0 to before 1.26.0 Fixed in 1.26.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:freelance-it-consultant:eu_cookie_compliance:*:*:*:*:*:drupal:*:* | before 8.x-1.26.0 | Vulnerable | Freelance-it-consultant |
- cpe:2.3:a:freelance-it-consultant:eu_cookie_compliance:*:*:*:*:*:drupal:*:* Versions before 8.x-1.26.0 Vulnerable ·Freelance-it-consultant
Remediation
- Fix · CNA EU Cookie Compliance (GDPR Compliance) (Drupal) Fixed in 1.26.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48917
- 2026-10-03 Alias added: GHSA-8pgm-2gj7-4gwj
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-48917 · CVE Program
- CVE-2025-48917 · NVD
- FIRST EPSS
- GHSA-8pgm-2gj7-4gwj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences