LibreNMS has Authenticated Local File Inclusion in ajax_form.php that Allows RCE
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-98.
Summary
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring which includes support for a wide range of network hardware and operating systems. LibreNMS versions 25.6.0 and below contain an architectural vulnerability in the ajax_form.php endpoint that permits Remote File Inclusion based on user-controlled POST input. The application directly uses the type parameter to dynamically include .inc.php files from the trusted path includes/html/forms/, without validation or allowlisting. This pattern introduces a latent Remote Code Execution (RCE) vector if an attacker can stage a file in this include path — for example, via symlink, development misconfiguration, or chained vulnerabilities. This is fixed in version 25.7.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 25.7.0 | 25.7.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 25.7.0 | 25.7.0 | Patch available | GHSA-gq96-8w38-hhj2 |
- librenms Vendorlibrenms Affected before 25.7.0 Fixed in 25.7.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 25.7.0 Fixed in 25.7.0 Patch available GHSA-gq96-8w38-hhj2
Remediation
- Fix · CNA librenms (librenms) Fixed in 25.7.0
- Fix · GHSA-gq96-8w38-hhj2 librenms/librenms (Packagist) Fixed in 25.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54138
- 2026-10-03 Alias added: GHSA-gq96-8w38-hhj2
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2025-54138 · CVE Program
- CVE-2025-54138 · NVD
- FIRST EPSS
- GHSA-gq96-8w38-hhj2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences