Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
A bypass of the DISALLOWED_SQL_FUNCTIONS security feature in Apache Superset allows for the execution of blocked SQL functions. An attacker can use a special inline block to circumvent the denylist. This allows a user with SQL Lab access to execute functions that were intended to be disabled, leading to the disclosure of sensitive database information like the software version. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | before 5.0.0 | 5.0.0 | Patch available | CNA |
| — | apache-superset (PyPI) | before 5.0.0 | 5.0.0 | Patch available | GHSA-fxgf-3xh6-m2pp |
- Apache Superset VendorApache Affected before 5.0.0 Fixed in 5.0.0 Patch available CNA
- apache-superset (PyPI) Vendor— Affected before 5.0.0 Fixed in 5.0.0 Patch available GHSA-fxgf-3xh6-m2pp
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 5.0.0
- Fix · GHSA-fxgf-3xh6-m2pp apache-superset (PyPI) Fixed in 5.0.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Superset 5.0.0
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2025-35106 Apache Superset: Incorrect datasource authorization on REST APIPriority LOW 25
- TI-2025-35103 Apache Superset: Stored XSS on charts metadataPriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2025-55674
- 2026-10-03 Alias added: GHSA-fxgf-3xh6-m2pp
References
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2025-55674 · CVE Program
- CVE-2025-55674 · NVD
- FIRST EPSS
- GHSA-fxgf-3xh6-m2pp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences