Read the docs
TI-2025-35106 Aliases CVE-2025-55675GHSA-mhpq-m962-mg92

Apache Superset: Incorrect datasource authorization on REST API

Priority LOW 25CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.

Summary

Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00648 51st percentileScored 2026-11-07
Fix Fixed Apache Superset (Apache Software Foundation): 5.0.0apache-superset (PyPI): 5.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Supersetbefore 5.0.05.0.0Patch availableCNA
—apache-superset (PyPI)before 5.0.05.0.0Patch availableGHSA-mhpq-m962-mg92
  • Apache Superset VendorApache Affected before 5.0.0 Fixed in 5.0.0 Patch available CNA
  • apache-superset (PyPI) Vendor— Affected before 5.0.0 Fixed in 5.0.0 Patch available GHSA-mhpq-m962-mg92

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*before 5.0.0VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions before 5.0.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 5.0.0
  • Fix · GHSA-mhpq-m962-mg92 apache-superset (PyPI) Fixed in 5.0.0 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apache Superset 5.0.0

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2025-35105 Apache Superset: Improper SQL authorisation, parse not checking for specific engine functionsPriority LOW 25
    • TI-2025-35103 Apache Superset: Stored XSS on charts metadataPriority LOW 25

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-55675
  2. 2026-10-03 Alias added: GHSA-mhpq-m962-mg92
  3. 2026-11-04 EPSS moved to the 50th–90th percentile

References

  • TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
See all 69 →

Sources