LibreNMS alert-rules Cross-Site Scripting Vulnerability
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LibreNMS is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts > Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00276 20th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms (librenms): 25.10.0librenms/librenms (Packagist): 25.10.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 25.10.0 | 25.10.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 25.10.0 | 25.10.0 | Patch available | GHSA-6g2v-66ch-6xmh |
- librenms Vendorlibrenms Affected before 25.10.0 Fixed in 25.10.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 25.10.0 Fixed in 25.10.0 Patch available GHSA-6g2v-66ch-6xmh
Remediation
- Fix · CNA librenms (librenms) Fixed in 25.10.0
- Fix · GHSA-6g2v-66ch-6xmh librenms/librenms (Packagist) Fixed in 25.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-62412
- 2026-10-03 Alias added: GHSA-6g2v-66ch-6xmh
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2025-62412 · CVE Program
- CVE-2025-62412 · NVD
- FIRST EPSS
- GHSA-6g2v-66ch-6xmh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences