LibreNMS has Weak Password Policy
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-521.
Summary
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.11.0, a weak password policy vulnerability was identified in the user management functionality of the LibreNMS application. This vulnerability allows administrators to create accounts with extremely weak and predictable passwords, such as 12345678. This exposes the platform to brute-force and credential stuffing attacks. This issue has been patched in version 25.11.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 25.11.0 | 25.11.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 25.11.0 | 25.11.0 | Patch available | GHSA-5mrf-j8v6-f45g |
- librenms Vendorlibrenms Affected before 25.11.0 Fixed in 25.11.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 25.11.0 Fixed in 25.11.0 Patch available GHSA-5mrf-j8v6-f45g
Remediation
- Fix · CNA librenms (librenms) Fixed in 25.11.0
- Fix · GHSA-5mrf-j8v6-f45g librenms/librenms (Packagist) Fixed in 25.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-65014
- 2026-10-03 Alias added: GHSA-5mrf-j8v6-f45g
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2025-65014 · CVE Program
- CVE-2025-65014 · NVD
- FIRST EPSS
- GHSA-5mrf-j8v6-f45g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences