LibreNMS is vulnerable to SQL Injection (Boolean-Based Blind) in hostname parameter in ajax_output.php endpoint
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.11.0, a boolean-based blind SQL injection vulnerability was identified in the LibreNMS application at the /ajax_output.php endpoint. The hostname parameter is interpolated directly into an SQL query without proper sanitization or parameter binding, allowing an attacker to manipulate the query logic and infer data from the database through conditional responses. This issue has been patched in version 25.11.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 25.11.0 | 25.11.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 25.11.0 | 25.11.0 | Patch available | GHSA-6pmj-xjxp-p8g9 |
- librenms Vendorlibrenms Affected before 25.11.0 Fixed in 25.11.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 25.11.0 Fixed in 25.11.0 Patch available GHSA-6pmj-xjxp-p8g9
Remediation
- Fix · CNA librenms (librenms) Fixed in 25.11.0
- Fix · GHSA-6pmj-xjxp-p8g9 librenms/librenms (Packagist) Fixed in 25.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-65093
- 2026-10-03 Alias added: GHSA-6pmj-xjxp-p8g9
- 2026-10-19 EPSS moved to the 90th–95th percentile
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2025-65093 · CVE Program
- CVE-2025-65093 · NVD
- FIRST EPSS
- GHSA-6pmj-xjxp-p8g9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences