Contao is vulnerable to cross-site scripting in templates
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves not using the affected templates or patch them manually.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| contao | contao | 4.0.0 to before 4.13.57; 5.0.0-RC1 to before 5.3.42; 5.4.0-RC1 to before 5.6.5 | 4.13.57, 5.3.42, 5.6.5 | Patch available | CNA |
| — | contao/core-bundle (Packagist) | 4.0.0 to before 4.13.57 | 4.13.57 | Patch available | GHSA-68q5-78xp-cwwc |
| — | contao/core-bundle (Packagist) | 5.0.0-RC1 to before 5.3.42 | 5.3.42 | Patch available | GHSA-68q5-78xp-cwwc |
| — | contao/core-bundle (Packagist) | 5.4.0-RC1 to before 5.6.5 | 5.6.5 | Patch available | GHSA-68q5-78xp-cwwc |
- contao Vendorcontao Affected 4.0.0 to before 4.13.57; 5.0.0-RC1 to before 5.3.42; 5.4.0-RC1 to before 5.6.5 Fixed in 4.13.57, 5.3.42, 5.6.5 Patch available CNA
- contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.13.57 Fixed in 4.13.57 Patch available GHSA-68q5-78xp-cwwc
- contao/core-bundle (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.3.42 Fixed in 5.3.42 Patch available GHSA-68q5-78xp-cwwc
- contao/core-bundle (Packagist) Vendor— Affected 5.4.0-RC1 to before 5.6.5 Fixed in 5.6.5 Patch available GHSA-68q5-78xp-cwwc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* | 4.0.0 to before 4.13.57; 5.0.0 to before 5.3.42; 5.4.0 to before 5.6.5 | Vulnerable | contao |
- cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.13.57; 5.0.0 to before 5.3.42; 5.4.0 to before 5.6.5 Vulnerable ·contao
Remediation
- Fix · CNA contao (contao) Fixed in 4.13.57, 5.3.42, 5.6.5
- Fix · GHSA-68q5-78xp-cwwc contao/core-bundle (Packagist) Fixed in 4.13.57 Advisory →
- Fix · GHSA-68q5-78xp-cwwc contao/core-bundle (Packagist) Fixed in 5.3.42 Advisory →
- Fix · GHSA-68q5-78xp-cwwc contao/core-bundle (Packagist) Fixed in 5.6.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-65961
- 2026-10-03 Alias added: GHSA-68q5-78xp-cwwc
References
More Contao vulnerabilities
- TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
- TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
- TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
- TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
- TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
Sources
- CVE-2025-65961 · CVE Program
- CVE-2025-65961 · NVD
- FIRST EPSS
- GHSA-68q5-78xp-cwwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences