LibreNMS Alert Rule API Cross-Site Scripting Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting. Alert rules can be created or updated via LibreNMS API. The alert rule name is not properly sanitized, and can be used to inject HTML code. This issue has been patched in version 25.12.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 25.12.0 | 25.12.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 25.12.0 | 25.12.0 | Patch available | GHSA-c89f-8g7g-59wj |
- librenms Vendorlibrenms Affected before 25.12.0 Fixed in 25.12.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 25.12.0 Fixed in 25.12.0 Patch available GHSA-c89f-8g7g-59wj
Remediation
- Fix · CNA librenms (librenms) Fixed in 25.12.0
- Fix · GHSA-c89f-8g7g-59wj librenms/librenms (Packagist) Fixed in 25.12.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-68614
- 2026-10-03 Alias added: GHSA-c89f-8g7g-59wj
- 2026-10-13 EPSS moved to the 90th–95th percentile
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2025-68614 · CVE Program
- CVE-2025-68614 · NVD
- FIRST EPSS
- GHSA-c89f-8g7g-59wj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences