Read the docs
TI-2026-01985 Aliases CVE-2026-2348GHSA-vmwp-f54q-chhh

Quick Edit - Moderately critical - Cross-site Scripting - SA-CONTRIB-2026-009

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Quick Edit allows Cross-Site Scripting (XSS).This issue affects Quick Edit: from 0.0.0 before 1.0.5, from 2.0.0 before 2.0.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00141 3rd percentileScored 2026-11-07
Fix Fixed Quick Edit (Drupal): 1.0.5, 2.0.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalQuick Edit0.0.0 to before 1.0.5; 2.0.0 to before 2.0.11.0.5, 2.0.1Patch availableCNA
  • Quick Edit VendorDrupal Affected 0.0.0 to before 1.0.5; 2.0.0 to before 2.0.1 Fixed in 1.0.5, 2.0.1 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:wim-leers:quick_edit:*:*:*:*:*:drupal:*:*before 1.0.5VulnerableWim-leers
cpe:2.3:a:wim-leers:quick_edit:2.0.0:*:*:*:*:drupal:*:*2.0.0VulnerableWim-leers
  • cpe:2.3:a:wim-leers:quick_edit:*:*:*:*:*:drupal:*:* Versions before 1.0.5 Vulnerable ·Wim-leers
  • cpe:2.3:a:wim-leers:quick_edit:2.0.0:*:*:*:*:drupal:*:* Versions 2.0.0 Vulnerable ·Wim-leers

Remediation

  • Fix · CNA Quick Edit (Drupal) Fixed in 1.0.5, 2.0.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-2348
  2. 2026-10-03 Alias added: GHSA-vmwp-f54q-chhh

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources