Cross-site scripting in librenms
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LibreNMS versions before 26.3.0 are affected by an authenticated Cross-site Scripting vulnerability on the showconfig page. Successful exploitation requires administrative privileges. Exploitation could result in XSS attacks being performed against other users with access to the page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 26.3.0 | 26.3.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | 25.12.0 to before 26.3.0 | 26.3.0 | Patch available | GHSA-5gm9-622f-qcg5 |
- librenms Vendorlibrenms Affected before 26.3.0 Fixed in 26.3.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected 25.12.0 to before 26.3.0 Fixed in 26.3.0 Patch available GHSA-5gm9-622f-qcg5
Remediation
- Fix · CNA librenms (librenms) Fixed in 26.3.0
- Fix · GHSA-5gm9-622f-qcg5 librenms/librenms (Packagist) Fixed in 26.3.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
librenms 26.3.0
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2026-05445 OS command injection in librenmsPriority HIGH 72
Timeline
- 2026-10-02 Threatist record created from CVE-2026-2728
- 2026-10-03 Alias added: GHSA-5gm9-622f-qcg5
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2026-2728 · CVE Program
- CVE-2026-2728 · NVD
- FIRST EPSS
- GHSA-5gm9-622f-qcg5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences