WooCommerce < 10.5.3 - Arbitrary Admin User Creation via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The WooCommerce WordPress plugin from versions 5.4.0 to 10.5.2 does not properly handle batch requests, which could allow unauthenticated users to make a logged in admin call non store/WC REST endpoints, and create arbitrary admin users via a CSRF attack for example.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Automattic | WooCommerce | 5.4.0 to before 5.4.4; 5.5.0 to before 5.4.5; 5.6.0 to before 5.6.3; 5.7.0 to before 5.7.3; 5.8.0 to before 5.8.2; 5.9.0 to before 5.9.2; 6.0.0 to before 6.0.2; 6.1.0 to before 6.1.3; 6.2.0 to before 6.2.3; 6.3.0 to before 6.3.2; 6.4.0 to before 6.4.2; 6.5.0 to before 6.5.2; 6.6.0 to before 6.6.2; 6.7.0 to before 6.7.1; 6.8.0 to before 6.8.3; 6.9.0 to before 6.9.5; 7.0.0 to before 7.0.2; 7.1.0 to before 7.1.2; 7.2.0 to before 7.2.4; 7.3.0 to before 7.3.1; 7.4.0 to before 7.4.2; 7.5.0 to before 7.5.2; 7.6.0 to before 7.6.2; 7.7.0 to before 7.7.3; 7.8.0 to before 7.8.4; 7.9.0 to before 7.9.2; 8.0.0 to before 8.0.5; 8.1.0 to before 8.1.4; 8.2.0 to before 8.2.5; 8.3.0 to before 8.3.4; 8.4.0 to before 8.4.3; 8.5.0 to before 8.5.5; 8.6.0 to before 8.6.4; 8.7.0 to before 8.7.3; 8.8.0 to before 8.8.7; 8.9.0 to before 8.9.5; 9.0.0 to before 9.0.4; 9.1.0 to before 9.1.7; 9.2.0 to before 9.2.5; 9.3.0 to before 9.3.6; 9.4.0 to before 9.4.5; 9.5.0 to before 9.5.4; 9.6.0 to before 9.6.4; 9.7.0 to before 9.7.3; 9.8.0 to before 9.8.7; 9.9.0 to before 9.9.7; 10.0.0 to before 10.0.6; 10.1.0 to before 10.1.4; 10.2.0 to before 10.2.4; 10.3.0 to before 10.3.8; 10.4.0 to before 10.4.4; 10.5.0 to before 10.5.3 | 5.4.4, 5.4.5, 5.6.3, 5.7.3, 5.8.2, 5.9.2, 6.0.2, 6.1.3, 6.2.3, 6.3.2, 6.4.2, 6.5.2, 6.6.2, 6.7.1, 6.8.3, 6.9.5, 7.0.2, 7.1.2, 7.2.4, 7.3.1, 7.4.2, 7.5.2, 7.6.2, 7.7.3, 7.8.4, 7.9.2, 8.0.5, 8.1.4, 8.2.5, 8.3.4, 8.4.3, 8.5.5, 8.6.4, 8.7.3, 8.8.7, 8.9.5, 9.0.4, 9.1.7, 9.2.5, 9.3.6, 9.4.5, 9.5.4, 9.6.4, 9.7.3, 9.8.7, 9.9.7, 10.0.6, 10.1.4, 10.2.4, 10.3.8, 10.4.4, 10.5.3 | Patch available | CNA |
- WooCommerce VendorAutomattic Affected 5.4.0 to before 5.4.4; 5.5.0 to before 5.4.5; 5.6.0 to before 5.6.3; 5.7.0 to before 5.7.3; 5.8.0 to before 5.8.2; 5.9.0 to before 5.9.2; 6.0.0 to before 6.0.2; 6.1.0 to before 6.1.3; 6.2.0 to before 6.2.3; 6.3.0 to before 6.3.2; 6.4.0 to before 6.4.2; 6.5.0 to before 6.5.2; 6.6.0 to before 6.6.2; 6.7.0 to before 6.7.1; 6.8.0 to before 6.8.3; 6.9.0 to before 6.9.5; 7.0.0 to before 7.0.2; 7.1.0 to before 7.1.2; 7.2.0 to before 7.2.4; 7.3.0 to before 7.3.1; 7.4.0 to before 7.4.2; 7.5.0 to before 7.5.2; 7.6.0 to before 7.6.2; 7.7.0 to before 7.7.3; 7.8.0 to before 7.8.4; 7.9.0 to before 7.9.2; 8.0.0 to before 8.0.5; 8.1.0 to before 8.1.4; 8.2.0 to before 8.2.5; 8.3.0 to before 8.3.4; 8.4.0 to before 8.4.3; 8.5.0 to before 8.5.5; 8.6.0 to before 8.6.4; 8.7.0 to before 8.7.3; 8.8.0 to before 8.8.7; 8.9.0 to before 8.9.5; 9.0.0 to before 9.0.4; 9.1.0 to before 9.1.7; 9.2.0 to before 9.2.5; 9.3.0 to before 9.3.6; 9.4.0 to before 9.4.5; 9.5.0 to before 9.5.4; 9.6.0 to before 9.6.4; 9.7.0 to before 9.7.3; 9.8.0 to before 9.8.7; 9.9.0 to before 9.9.7; 10.0.0 to before 10.0.6; 10.1.0 to before 10.1.4; 10.2.0 to before 10.2.4; 10.3.0 to before 10.3.8; 10.4.0 to before 10.4.4; 10.5.0 to before 10.5.3 Fixed in 5.4.4, 5.4.5, 5.6.3, 5.7.3, 5.8.2, 5.9.2, 6.0.2, 6.1.3, 6.2.3, 6.3.2, 6.4.2, 6.5.2, 6.6.2, 6.7.1, 6.8.3, 6.9.5, 7.0.2, 7.1.2, 7.2.4, 7.3.1, 7.4.2, 7.5.2, 7.6.2, 7.7.3, 7.8.4, 7.9.2, 8.0.5, 8.1.4, 8.2.5, 8.3.4, 8.4.3, 8.5.5, 8.6.4, 8.7.3, 8.8.7, 8.9.5, 9.0.4, 9.1.7, 9.2.5, 9.3.6, 9.4.5, 9.5.4, 9.6.4, 9.7.3, 9.8.7, 9.9.7, 10.0.6, 10.1.4, 10.2.4, 10.3.8, 10.4.4, 10.5.3 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:*:*:* | — | — | WooCommerce |
- cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:*:*:* Versions — — ·WooCommerce
Remediation
- Fix · CNA WooCommerce (Automattic) Fixed in 5.4.4, 5.4.5, 5.6.3, 5.7.3, 5.8.2, 5.9.2, 6.0.2, 6.1.3, 6.2.3, 6.3.2, 6.4.2, 6.5.2, 6.6.2, 6.7.1, 6.8.3, 6.9.5, 7.0.2, 7.1.2, 7.2.4, 7.3.1, 7.4.2, 7.5.2, 7.6.2, 7.7.3, 7.8.4, 7.9.2, 8.0.5, 8.1.4, 8.2.5, 8.3.4, 8.4.3, 8.5.5, 8.6.4, 8.7.3, 8.8.7, 8.9.5, 9.0.4, 9.1.7, 9.2.5, 9.3.6, 9.4.5, 9.5.4, 9.6.4, 9.7.3, 9.8.7, 9.9.7, 10.0.6, 10.1.4, 10.2.4, 10.3.8, 10.4.4, 10.5.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3589
- 2026-10-03 Alias added: GHSA-2wr3-vxcp-rxmc
References
More Automattic vulnerabilities
- TI-2023-12700 Improper authentication in WooCommerce Payments WordPress Plugin CVSS 3.1CRITICAL 9.8
- TI-2023-03453 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2024-06106 Jetpack Boost < 3.4.7 - Admin+ SSRF CVSS 3.1CRITICAL 9.1
- TI-2013-01782 WordPress W3 Total Cache Plugin 0.9.2.8 has a Remote PHP Code Execution Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-02368 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2023-02806 Jetpack < 12.1.1 - Author+ Arbitrary File Manipulation via API CVSS 3.1HIGH 8.8
Sources
- CVE-2026-3589 · CVE Program
- CVE-2026-3589 · NVD
- FIRST EPSS
- GHSA-2wr3-vxcp-rxmc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences