Read the docs
TI-2026-11237 Aliases CVE-2026-13233GHSA-65px-3fq7-92h3

OpenAI Provider - Moderately critical - Server-side Request Forgery - SA-CONTRIB-2026-053

Priority LOW 15CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

Server-Side Request Forgery (SSRF) vulnerability in Drupal OpenAI Provider allows Server Side Request Forgery. This issue affects OpenAI Provider versions: from 0.0.0 to 1.1.1, from 1.2.0 to 1.2.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00208 10th percentileScored 2026-11-07
Fix Fixed OpenAI Provider (Drupal): 1.1.1, 1.2.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalOpenAI Provider0.0.0 to before 1.1.1; 1.2.0 to before 1.2.21.1.1, 1.2.2Patch availableCNA
  • OpenAI Provider VendorDrupal Affected 0.0.0 to before 1.1.1; 1.2.0 to before 1.2.2 Fixed in 1.1.1, 1.2.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:openai_provider_project:openai_provider:*:*:*:*:*:drupal:*:*before 1.1.1; 1.2.0 to before 1.2.2VulnerableOpenai Provider Project
  • cpe:2.3:a:openai_provider_project:openai_provider:*:*:*:*:*:drupal:*:* Versions before 1.1.1; 1.2.0 to before 1.2.2 Vulnerable ·Openai Provider Project

Remediation

  • Fix · CNA OpenAI Provider (Drupal) Fixed in 1.1.1, 1.2.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-13233
  2. 2026-10-03 Alias added: GHSA-65px-3fq7-92h3

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources