Cross-site scripting in Link Library
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Link Library allows Cross-Site Scripting (XSS). This issue affects Link Library: before 7.9.4.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00276 20th percentileScored 2026-11-07
Fix Fixed Link Library: 7.9.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Link Library | before 7.9.4 | 7.9.4 | Patch available | CNA |
- Link Library Vendor— Affected before 7.9.4 Fixed in 7.9.4 Patch available CNA
Remediation
- Fix · CNA Link Library Fixed in 7.9.4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-18197
- 2026-10-03 Alias added: GHSA-c9gj-8f9h-hp8h
References
More jackdewey Link Library vulnerabilities
- TI-2022-03844 Link Library < 7.4.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-16389 WordPress Link Library Plugin <= 7.5.13 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-01455 Link Library <= 7.6 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.5
- TI-2021-07371 Link Library < 7.2.8 - Unauthenticated Arbitrary Links Deletion CVSS 3.1HIGH 7.5
- TI-2024-19297 WordPress Link Library plugin <= 7.6 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-25945 WordPress Link Library plugin <= 7.7.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2026-18197 · CVE Program
- CVE-2026-18197 · NVD
- FIRST EPSS
- GHSA-c9gj-8f9h-hp8h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences