Read the docs
TI-2026-19324 Aliases CVE-2026-23982GHSA-3m2g-v7jf-7fxc

Apache Superset: Improper Authorization in Dataset Creation Allows Access Control Bypass

Priority LOW 32CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00514 44th percentileScored 2026-11-07
Fix Fixed Apache Superset (Apache Software Foundation): 6.0.0apache-superset (PyPI): 6.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Superset0.0.0 to before 6.0.06.0.0Patch availableCNA
—apache-superset (PyPI)before 6.0.06.0.0Patch availableGHSA-3m2g-v7jf-7fxc
  • Apache Superset VendorApache Affected 0.0.0 to before 6.0.0 Fixed in 6.0.0 Patch available CNA
  • apache-superset (PyPI) Vendor— Affected before 6.0.0 Fixed in 6.0.0 Patch available GHSA-3m2g-v7jf-7fxc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*before 6.0.0VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions before 6.0.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 6.0.0
  • Fix · GHSA-3m2g-v7jf-7fxc apache-superset (PyPI) Fixed in 6.0.0 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apache Superset 6.0.0

    4 records Highest priority Priority LOW 4 LOW

    Other records, highest priority first

    • TI-2026-19326 Apache Superset: SQLLab Read-Only Bypass on PostgreSQLPriority LOW 31
    • TI-2026-19322 Apache Superset: Improper Neutralization of Special Elements used in a SQL CommandPriority LOW 25
    • TI-2026-19325 Apache Superset: Sensitive Data Exposure via REST API (disabled by default)Priority LOW 12

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-23982
  2. 2026-10-03 Alias added: GHSA-3m2g-v7jf-7fxc

References

  • TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
See all 69 →

Sources